2023/2/2(木)バージョンアップ後、一部の名刺情報がエラーとして格納される
2023/02/20
お世話になっております。PHONE APPLIサポート窓口でございます。
平素はPHONE APPLI PEOPLE for Salesforceをご利用頂きまして、ありがとうございます。
現在PHONE APPLI PEOPLE for Salesforceの名刺アップロードにおいて、以下、複数の事象発生を確認しております。
事象の内容や今後の対応について、以下に記載いたします。
事象の内容・発生条件
①名刺アップロードに関するエラー
①-1. 社外連絡先へアップロードした名刺情報が「入力エラー」、「OCR読み取りエラー」として格納される。
※以下でご案内させていただいているものと同様
https://help.phoneappli.net/pap-for-sf/info/I-000137
発生条件
一部文字が機械OCR、オペレータ入力時に読み取れない画像(ピントがあっていない画像など)を登録した場合に発生しております。
対象のお客様
PHONE APPLI PEOPLE for Salesforce ver2.20049 の 一部のユーザ様において、本事象が発生しております。
また、上記の条件に該当しない名刺についても本件の影響が発生している可能性がございます。
こちらも同様に後述のリカバリ方法に記載している通り、弊社で対象データを再送信いたします。
①-2. 社外連絡先へアップロードした名刺情報が「入力エラー」、「OCR読み取りエラー」として格納されているが、取引先連携が行われている可能性がある。
※氏名、住所、メールアドレス等、名刺の情報は正しく格納されておりますので、取引先連携が行われていた場合においても、取引先・取引先責任者には正しいデータが登録・更新されております。
発生条件
一部文字が機械OCR、オペレータ入力時に読み取れない画像(ピントがあっていない画像など)を登録している、かつ、取引先連携を利用する設定で名刺登録を行っている場合
対象のお客様
PHONE APPLI PEOPLE for Salesforce ver2.20049 の 一部のユーザ様において、本事象が発生しております。
また、上記の条件に該当しない名刺についても本件の影響が発生している可能性がございます。
こちらも同様に後述のリカバリ方法に記載している通り、弊社で対象データを再送信いたします。
②取引先連携に関するエラー
②-1. 特定の条件で取引先連携に失敗する。
発生条件
下記の3つの条件をすべて満たす場合に発生しております。
1.Salesforceの設定「州/国/テリトリー選択リスト」を有効化している
2.管理者設定 -> 取引先連携マッピングにて、以下の項目とマッピングしている社外連絡先の項目が空となっている
・都道府県(請求先)
・市区郡(請求先)
・町名・番地(請求先)
・郵便番号(納入先)
・都道府県(納入先)
・市区郡(納入先)
3.取引先連携時に、取引先、または取引先責任者を更新する(一致条件に合致する既存の取引先、取引先責任者が存在する)
対象のお客様
PHONE APPLI PEOPLE for Salesforce ver2.20049 の 一部のユーザ様において、本事象が発生しております。
原因
PHONE APPLI PEOPLE for Salesforce ver2.20049 にて、Spring'23への対応を実施しておりましたが、改修内容に不備があったため、本事象が発生いたしました。
回避方法と今後の対応
①名刺アップロードに関するエラーの今後の対応について
①-1. 社外連絡先へアップロードした名刺情報が「入力エラー」、「OCR読み取りエラー」として格納される。
回避方法
修正版パッケージへのアップデートを実施いたします。
後述するアップデート日までは発生条件に該当する名刺画像のOCR処理、オペレータ入力依頼をお控えくださいますようお願いいたします。
今後の対応
2⽉27⽇(⽉)18:00〜21:00に修正版パッケージへのアップデート、及び、データ再送信(リカバリ作業)を実施いたします。
当アップデート作業により、本事象は発生しなくなります。
リカバリ
パッケージのアップデート後に、弊社にて作業を行います。
※お客様による作業や対応は不要です。
※本作業ではお客様のSalesforce組織へのログインは行いません。
①-2. 社外連絡先へアップロードした名刺情報が「入力エラー」、「OCR読み取りエラー」として格納されている
回避方法
修正版パッケージへのアップデートを実施いたします。
後述するアップデート日までは発生条件に該当する名刺画像のOCR処理、オペレータ入力依頼をお控えくださいますようお願いいたします。
今後の対応
2⽉27⽇(⽉)18:00〜21:00に修正版パッケージへのアップデート、及び、データ再送信(リカバリ作業)を実施いたします。
当アップデート作業により、本事象は発生しなくなります。
リカバリ
パッケージのアップデート後に、弊社にて作業を行います。
※お客様による作業や対応は不要です。
※本作業ではお客様のSalesforce組織へのログインは行いません。
②取引先連携に関するエラーの今後の対応について
②-1. 特定の条件で取引先連携に失敗する。
回避方法
修正版パッケージへのアップデートを実施いたします。
今後の対応
2⽉27⽇(⽉)18:00〜21:00に修正版パッケージへのアップデートを実施いたします。
当アップデート作業により、本事象は発生しなくなります。
リカバリ
パッケージのアップデート後に、再度取引先連携を実施していただきますようお願いいたします。
以上となります。
よろしくお願い申し上げます。