【復旧済み】1月18日24:30 更新【重要】PHONE APPLI LINER一部機能の障害発生について

2022/12/02

お客様各位

お世話になっております。PHONE APPLIサポート窓口でございます。

平素はPHONE APPLI LINERをご利用頂きまして、ありがとうございます。

主題の件、現在、PHONE APPLI LINERの一部機能に障害が発生しており、リアルタイム表示ができない状態です。
本障害の対応状況についてはこちらで随時更新いたします。ご確認のほどよろしくお願いいたします。

復旧済みのお客様環境

・ver. 2.100007

・ver. 1.560004

実施済みのメンテナンス日時

・2022年12月2日(金)26:00~27:44

・2022年12月3日(土)24:00~24:26

・2022年12月9日(金)24:00〜24:30

・2023年  1月18日(水)24:00〜24:30

本事象について

事象:

(1) 1対1チャット:チャットのリアルタイム表示ができない
(2) チャットコンソール:チャットのリアルタイム表示ができない
(3) リアルタイム通知(旧通知)が利用できない

上記(1)(2)については、手動でのブラウザリロード(再読み込み)操作により、内容は更新されます。
※ただし、SalesforceのCanvas利用における回数の制約がございますのでご注意ください。

Salesforceの制約に関する詳細は、以下URLをご参照ください。
https://developer.salesforce.com/docs/atlas.ja-jp.platform_connect.meta/platform_connect/canvas_framework_limits.htm


その他機能(友達登録、メッセージの一斉配信、1対1チャットの送受信、オプション機能等)は問題なくご利用いただけている事を確認しております。

影響範囲:PHONE APPLI LINERをお使いのすべてのお客様

発生ver:PHONE APPLI LINER すべてのバージョン

発生時刻:12月2日 16:30~

原因と対策について

この度はPHONE APPLI LINERのサーバ負荷増大にともなうリアルタイム処理のサーバダウンが発生し、リアルタイム処理がご利用いただけなくなり大変申し訳ございません。原因と実施した対策については下記のとおりです。

今後は、これまで以上に負荷テストならびに負荷分散処理を十分に実施し、同様のことが発生しないように努めて参りますので、何卒よろしくお願い申し上げます。

原因

  • LINERはマルチテナントを採用しておりサーバの負荷については注視を続けておりましたが、顧客数増加に伴って負荷が増加傾向にあったため、ver2.10へのアップデートのタイミングでリアルタイム処理を含む一部の負荷軽減を目指したプログラムの見直しを実施しておりました。
  • 一方でver2.10では負荷が増える処理も増えていたため併せて負荷テストは実施していたものの、上記の調整を実施してもそれを更に上回る負荷が発生してしまい、リアルタイム処理のサーバがダウンしてしまったことが原因です。

実施した対策

  • 上記のすべてを考慮した、バージョンごとの大幅な処理の見直しを実施(対象の処理は各バージョンで調整が必要なため)
  • その中で、ご利用対象の一番多いバージョンから順次対応を進めた結果、最新バージョンのお客様から順次復旧作業を行う運びとなりました。

ご迷惑をおかけしております事を深くお詫びいたします。

復旧に向けて全力で取り組んでまいりますので、何卒よろしくお願い申し上げます。

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